注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

冰魂's blog

关注网络技术.

 
 
 
 
 

日志

 
 

易语言 sql数据库 高级表格应用[图+源码]  

2011-08-17 22:26:02|  分类: [程序设计] |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
易语言 sql数据库 高级表格应用[图+源码] - 关注Web安全 - 冰魂s blog

 

 

源码如下:

 版本 2
.支持库 eGrid
.支持库 eDB

.子程序 _按钮1_被单击
.局部变量 计次, 整数型
.局部变量 临时存放, 文本型
.局部变量 临时变量, 整数型

高级表格1.置数据 (0, 0, #表格常量.文本型, “ID”)
高级表格1.置列宽 (0, 60)
高级表格1.置数据 (0, 1, #表格常量.文本型, “用户名”)
高级表格1.置列宽 (0, 60)
高级表格1.置数据 (0, 2, #表格常量.文本型, “密码”)
高级表格1.置列宽 (0, 60)
.如果 (数据库连接1.连接SQLServer (“192.168.0.10”, “local”, “sa”, “”) = 真)
    信息框 (“数据库成功”, 0, )
.否则
    信息框 (“数据失败”, 0, )
.如果结束
记录集1.置连接 (数据库连接1)
记录集1.打开 (“select *from admin”, #SQL语句)
高级表格1.行数 = 记录集1.记录数量 + 1

.计次循环首 (记录集1.记录数量, 计次)

    记录集1.读文本 (0, 临时存放)
    高级表格1.置数据 (计次, 0, #表格常量.文本型, 临时存放)
    记录集1.读文本 (1, 临时存放)
    高级表格1.置数据 (计次, 1, #表格常量.文本型, 临时存放)
    记录集1.读文本 (2, 临时存放)
    高级表格1.置数据 (计次, 2, #表格常量.文本型, 临时存放)


    .' 计次循环首 (3, 临时变量)         ;假定是3行的情况下。这个3可以另外设变量

        ' 记录集1.读文本 (临时变量 - 1, 临时存放)
        ' 高级表格1.置数据 (计次, 临时变量 - 1, #表格常量.文本型, 临时存放)

    .' 计次循环尾 ()
    记录集1.到下一条 ()


.计次循环尾 ()

  评论这张
 
阅读(1461)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017